金沢に住む理系大学院生が運営するブログです。読んだ本、行った場所、買ったものの記録。

The `rails’ command exists in these Ruby versions:

 
この記事を書いている人 - WRITER -
金沢の地でWEB技術を勉強中。 世界をもっと面白くする。

背景

Reactを勉強中をしたいなと思い、RailsのAPIをReactから叩けるようなアプリケーションの開発中の出来事。

Railsをインストールし、その後に

$ rails --version

をしたときに発生したエラー。

開発環境

日付:2019/10/19

Ruby :2.5.1
Rails :6.0.0

エラー内容

The `rails' command exists in these Ruby versions:

意味的には「このバージョンではrailsコマンドは使えないよ」とのこと

解決方法

$ gem install rails

にて解決しました。

原因は、rbenvを使ってRubyの新しいバージョンを入れて切り替えていたことだったみたいです。
rbenvのバージョン管理とその他のgem管理など、理解があいまいなのでもうちょっと正確に理解したいです。

参考サイト

https://qiita.com/kamillle/items/5a7befd0ebad47378832

この記事を書いている人 - WRITER -
金沢の地でWEB技術を勉強中。 世界をもっと面白くする。
スポンサーリンク




スポンサーリンク




Copyright© AMALOG , 2019 All Rights Reserved.